[AXIS2} v1.7.6 not appearing as Axis2 Wizard in Eclipse Neon

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[AXIS2} v1.7.6 not appearing as Axis2 Wizard in Eclipse Neon

HUSSEY, STEPHEN LANCE

I have installed Eclipse Neon and AXIS2 1.7.6 service generator plug-in.  I can run the wsdl2java at a command prompt without issue.  I cannot get Eclipse to make the AXIS2 Wizards available under New -> Other.

 

I have tried dropping the jar file in both the dropins and the plugins directories.  This is on a Windows 10 64 bit install.  Eclipse is v4.6.3.  Eclipse is running from c:\Users\userid\Eclipse.

 

When I run Eclipse with the console option, no error messages are displayed and the ss axis2 command reflects the following information:

 

ss axis2

"Framework is launched."

 

id      State       Bundle

518     ACTIVE      org.eclipse.jst.ws.axis2.consumption.core_1.0.200.v201309242118

519     ACTIVE      org.eclipse.jst.ws.axis2.consumption.ui_1.0.200.v201309242118

520     ACTIVE      org.eclipse.jst.ws.axis2.core_1.0.300.v201309242118

521     ACTIVE      org.eclipse.jst.ws.axis2.creation.core_1.0.200.v201309242118

522     ACTIVE      org.eclipse.jst.ws.axis2.creation.ui_1.0.200.v201309242118

523     ACTIVE      org.eclipse.jst.ws.axis2.ui_1.0.400.v201309242118

524     ACTIVE      org.eclipse.jst.ws.axis2.ui.doc.user_1.0.200.v201309242118

 

Please give me some ideas or guidance on how to get the AXIS2 wizards activated so that I can generate the .aar files.

 

Stephen L. Hussey
Lead - System Architect

Reply | Threaded
Open this post in threaded view
|

Re: [AXIS2} v1.7.6 not appearing as Axis2 Wizard in Eclipse Neon

robertlazarski .


On Mon, Oct 30, 2017 at 4:16 PM, HUSSEY, STEPHEN LANCE <[hidden email]> wrote:

I have installed Eclipse Neon and AXIS2 1.7.6 service generator plug-in.  I can run the wsdl2java at a command prompt without issue.  I cannot get Eclipse to make the AXIS2 Wizards available under New -> Other.

 

I have tried dropping the jar file in both the dropins and the plugins directories.  This is on a Windows 10 64 bit install.  Eclipse is v4.6.3.  Eclipse is running from c:\Users\userid\Eclipse.

 

When I run Eclipse with the console option, no error messages are displayed and the ss axis2 command reflects the following information:

 

ss axis2

"Framework is launched."

 

id      State       Bundle

518     ACTIVE      org.eclipse.jst.ws.axis2.consumption.core_1.0.200.v201309242118

519     ACTIVE      org.eclipse.jst.ws.axis2.consumption.ui_1.0.200.v201309242118

520     ACTIVE      org.eclipse.jst.ws.axis2.core_1.0.300.v201309242118

521     ACTIVE      org.eclipse.jst.ws.axis2.creation.core_1.0.200.v201309242118

522     ACTIVE      org.eclipse.jst.ws.axis2.creation.ui_1.0.200.v201309242118

523     ACTIVE      org.eclipse.jst.ws.axis2.ui_1.0.400.v201309242118

524     ACTIVE      org.eclipse.jst.ws.axis2.ui.doc.user_1.0.200.v201309242118

 

Please give me some ideas or guidance on how to get the AXIS2 wizards activated so that I can generate the .aar files.

 

Stephen L. Hussey
Lead - System Architect


You don't see to have the right jar. You should be seeing this:

osgi> ss axis2
"Framework is launched."


id      State       Bundle
304     STARTING    org.apache.axis2.eclipse.codegen.plugin_1.7.6

Your dropins folder should contain axis2.eclipse.codegen.plugin-1.7.6.jar , from axis2-eclipse-codegen-plugin-1.7.6.zip in the downloads section.