[Axis2] Java Upgrade - 7

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Axis2] Java Upgrade - 7

Ashish Mantri
Hi,

I am planning to upgrade JDK version from 6 to 7 for my project. 
I am using axis2 - 1.5 to generate client code for WS call. 

Can you please let me know if axis2 - 1.5 will be supported on JDK 7 or i will need to upgrade axis 2 for latest version. 

Thanks and Regards,
Ashish Mantri
Reply | Threaded
Open this post in threaded view
|

Re: [Axis2] Java Upgrade - 7

Andreas Veithen-2
That is a question you will not get a definitive answer for. First of
all, Axis2 1.5 isn't supported on any platform, in the sense that
there will be no maintenance releases for the 1.5 branch. Second, if
you look at the release dates for 1.5.x, you will see that with the
exception of 1.5.6, all releases happened before Java 7 became
available. 1.5.6 was releases a few weeks after that, but as far as I
know it hadn't been extensively tested on Java 7. That being said,
chances are high that it will just work. The problem is that a typical
project that depends on Axis2 will only actually use a small fraction
of the code, and even if we had an exhaustive list of known issues
with Java 7, it would be virtually impossible to predict if your
project would actually encounter any of these issues.

Anyway, software projects are expected to have sufficient test
coverage and it should therefore just be a matter of executing your
test suite with Java 7...

Andreas


On Mon, Nov 23, 2015 at 7:43 AM, Ashish Mantri <[hidden email]> wrote:

> Hi,
>
> I am planning to upgrade JDK version from 6 to 7 for my project.
> I am using axis2 - 1.5 to generate client code for WS call.
>
> Can you please let me know if axis2 - 1.5 will be supported on JDK 7 or i
> will need to upgrade axis 2 for latest version.
>
> Thanks and Regards,
> Ashish Mantri

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]