Axis2c build fails in neethi

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Axis2c build fails in neethi

slowpoison
I'm running Ubuntu 9.10 Karmic Koala. When I try to build
axis2c-src-1.6.0, I get the following error:

/bin/bash ../libtool --tag=CC   --mode=link gcc -g -O2 -pthread -Wall
-D_LARGEFILE64_SOURCE -ansi -Wall -Werror
-Wno-implicit-function-declaration   -lpthread -o test test.o
../src/libneethi.la ../../axiom/src/om/libaxis2_axiom.la
../../util/src/libaxutil.la ../src/libneethi.la -ldl
mkdir .libs
gcc -g -O2 -pthread -Wall -D_LARGEFILE64_SOURCE -ansi -Wall -Werror
-Wno-implicit-function-declaration -o .libs/test test.o  -lpthread
../../axiom/src/om/.libs/libaxis2_axiom.so
../../util/src/.libs/libaxutil.so ../src/.libs/libneethi.so -ldl
-Wl,--rpath -Wl,/usr/lib/axis2c/lib
/usr/bin/ld: test.o: in function load_policy_array:test.c:185: error:
undefined reference to 'axiom_xml_reader_create_for_file'
/usr/bin/ld: test.o: in function load_policy_array:test.c:198: error:
undefined reference to 'axiom_xml_reader_free'
/usr/bin/ld: test.o: in function om_node_serialize:test.c:143: error:
undefined reference to 'axiom_xml_writer_create_for_memory'
/usr/bin/ld: test.o: in function om_node_serialize:test.c:158: error:
undefined reference to 'axiom_xml_writer_get_xml'
/usr/bin/ld: test.o: in function main:test.c:32: error: undefined
reference to 'axiom_xml_reader_create_for_file'
/usr/bin/ld: test.o: in function main:test.c:45: error: undefined
reference to 'axiom_xml_reader_free'
collect2: ld returned 1 exit status

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Axis2c build fails in neethi

Selvaratnam Uthaiyashankar
What are the configure options you have given? Are you using libxml2
or guththila? Can you enable guththila and see whether you are getting
same error.

Regards,
Shankar

On Fri, Apr 2, 2010 at 1:39 AM, slowpoison <[hidden email]> wrote:

> I'm running Ubuntu 9.10 Karmic Koala. When I try to build
> axis2c-src-1.6.0, I get the following error:
>
> /bin/bash ../libtool --tag=CC   --mode=link gcc -g -O2 -pthread -Wall
> -D_LARGEFILE64_SOURCE -ansi -Wall -Werror
> -Wno-implicit-function-declaration   -lpthread -o test test.o
> ../src/libneethi.la ../../axiom/src/om/libaxis2_axiom.la
> ../../util/src/libaxutil.la ../src/libneethi.la -ldl
> mkdir .libs
> gcc -g -O2 -pthread -Wall -D_LARGEFILE64_SOURCE -ansi -Wall -Werror
> -Wno-implicit-function-declaration -o .libs/test test.o  -lpthread
> ../../axiom/src/om/.libs/libaxis2_axiom.so
> ../../util/src/.libs/libaxutil.so ../src/.libs/libneethi.so -ldl
> -Wl,--rpath -Wl,/usr/lib/axis2c/lib
> /usr/bin/ld: test.o: in function load_policy_array:test.c:185: error:
> undefined reference to 'axiom_xml_reader_create_for_file'
> /usr/bin/ld: test.o: in function load_policy_array:test.c:198: error:
> undefined reference to 'axiom_xml_reader_free'
> /usr/bin/ld: test.o: in function om_node_serialize:test.c:143: error:
> undefined reference to 'axiom_xml_writer_create_for_memory'
> /usr/bin/ld: test.o: in function om_node_serialize:test.c:158: error:
> undefined reference to 'axiom_xml_writer_get_xml'
> /usr/bin/ld: test.o: in function main:test.c:32: error: undefined
> reference to 'axiom_xml_reader_create_for_file'
> /usr/bin/ld: test.o: in function main:test.c:45: error: undefined
> reference to 'axiom_xml_reader_free'
> collect2: ld returned 1 exit status
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
S.Uthaiyashankar
Software Architect
WSO2 Inc.
http://wso2.com/ - "lean . enterprise . middleware"

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Axis2c build fails in neethi

slowpoison
On Thu, Apr 1, 2010 at 6:06 PM, Selvaratnam Uthaiyashankar
<[hidden email]> wrote:
> What are the configure options you have given? Are you using libxml2
> or guththila? Can you enable guththila and see whether you are getting
> same error.

I have tried both without options and --with-guththila and still get
the same error.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Axis2c build fails in neethi

Samisa Abeysinghe-4
Have you set your library path?

On Fri, Apr 2, 2010 at 7:20 AM, slowpoison <[hidden email]> wrote:
On Thu, Apr 1, 2010 at 6:06 PM, Selvaratnam Uthaiyashankar
<[hidden email]> wrote:
> What are the configure options you have given? Are you using libxml2
> or guththila? Can you enable guththila and see whether you are getting
> same error.

I have tried both without options and --with-guththila and still get
the same error.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Axis2c build fails in neethi

slowpoison
In reply to this post by slowpoison
On Thu, Apr 1, 2010 at 6:50 PM, slowpoison <[hidden email]> wrote:
> I have tried both without options and --with-guththila and still get
> the same error.

I finally solved this by running these in order:
aclocal
autoheader
libtoolize
autoconf
automake --add-missing
make

So, looks like my compile problems were related to autoconf/automake.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]