Can I use “selenium” in the axis2 web service client?‏

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Can I use “selenium” in the axis2 web service client?‏

김홍수

How are you? I made a web service client by AXIS2. It works fine. And I needed to grab an information from web page and relay it to the server using my web service client. So I decided to use selenium+WebDriver.

I developed it separately. So my web service client works fine and my selenium based scrapper works fine. I confirmed it. I merged the source but my program didn't work. Because firefoxDriver(with Xvfb solution) or HtmlUnitDriver didn't work properly. I tested it again by separated program, and each program worked fine.

Can I run selenium code in the axis2 based web service client? Do I need to set something? Or is there a sort of library confliction between axis2 and selenium 2.0?


 I copied selenium 2.0's library files(JAR) to the axis2's lib directory

[my code in axs2 client] 

System.out.println("before FirefoxDriver()");

WebDriver driver = new FirefoxDriver();

System.out.println("after FirefoxDriver()");




[console]

[loess4u@localhost EnergyCollectWS]ant jar.client

Buildfile: /home/loess4u/workspace/EnergyCollectWS/build.xml


init:


jar.xbeans:


pre.compile.test:

     [echo] XmlBeans Availability = true

     [echo] Stax Availability= true

     [echo] Axis2 Availability= true


compile.src:

    [javac] /home/loess4u/workspace/EnergyCollectWS/build.xml:50: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds


jar.client:

      [jar] Building jar: /home/loess4u/workspace/EnergyCollectWS/build/lib/EnergyCollectWS-test-client.jar


BUILD SUCCESSFUL

Total time: 2 seconds

[loess4u@localhost EnergyCollectWS]$ cp ./build/lib/EnergyCollectWS-test-client.jar /opt/axis2-1.6.2/lib/

[loess4u@localhost EnergyCollectWS]$ axis2.sh com.bspower.energycollect.ws.Client

 Using AXIS2_HOME: /opt/axis2-1.6.2

 Using JAVA_HOME:  /usr/java/jdk1.7.0_45

[INFO] Clustering has been disabled

Feb 02, 2014 8:10:08 PM org.apache.axis2.deployment.util.TempFileManager <clinit>

INFO: TempFileManager::unable to delete /tmp/axis2-tmp-53143774169031012.tmp

[INFO] Deploying module: addressing-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/addressing-1.6.2.mar

[INFO] Deploying module: soapmonitor-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/soapmonitor-1.6.2.mar

[INFO] Deploying module: ping-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/ping-1.6.2.mar

[INFO] Deploying module: mtompolicy-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/mtompolicy-1.6.2.mar

[INFO] Deploying module: metadataExchange-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/mex-1.6.2.mar

[INFO] Deploying module: script-1.6.2 - file:/opt/axis2-1.6.2/repository/modules/scripting-1.6.2.mar

[INFO] Deploying Web service: StockQuoteService.aar - file:/opt/axis2-1.6.2/repository/services/StockQuoteService.aar

[INFO] Deploying Web service: version.aar - file:/opt/axis2-1.6.2/repository/services/version.aar

before FirefoxDriver()


And then, program stops. 

FirefoxDriver() never return. 


Please help me to solve this problem.


Thank you.