Problems with Axis on JBoss 4.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with Axis on JBoss 4.0

Kunze, Kai
Hi all,

I hope u guys can help me.

I had a WebService running on Jboss 3.2.6, which I deployed with the
AdminClient-Tool and a self-written deploy.wsdd file.
It all worked fine and it was easy to deploy. Now we upgraded to
4.0.1sp1 and there are severeal problems that I have now.

1. The AdminClient-Tool doesnt work anymore. I tried to deploy the WS
the same way as before but it doesnt work. The output was something like
"..Connection failed!..".

2. So I tried to create a WAR-package. But I have HashMaps in my WS as
return-type, and JBoss wont accept them. Do I have to specify such
things in the "jaxrpc-mapping.xml" - file? If I cut out all
HashMap-methods, Jboss accepts the WAR-file.

3. I have problems to specify the correct endpoint of the WS.
F.e. u know that the Version-Service is by default at:
"http://server-dns-name:8080/ws4ee/services/Version?wsdl"
I want my WS to be located at:
"http://server-ds-name:8080/ws4ee/services/WS-Name?wsdl"
Actually my WebService is at:
"http://server-IP:8080/WS-Name/ws4ee/services/WS-Name?wsdl"

The worst thing is, that I cant access it by ist dns-name, only directly
by the IP. I dont specify the IP in any XML-File. How can that happen?

In which file do I set it? Which tag do i use?
- web.xml?
- jaxrpc-mapping.xml ?
- webservice.xml ?

If u think u can help me, I can send u XML-Files and Source Code if u
like...

Greetings and thx in advance,

Kai

--
Kai Kunze
Braunschweig, Germany
Reply | Threaded
Open this post in threaded view
|

RE: Problems with Axis on JBoss 4.0

Kees van Dieren-3
Hi,

Jboss has a wiki about webservices:
http://wiki.jboss.org/wiki/Wiki.jsp?page=JBossWS


It contains the information u need to make webservices working.



Kind regards,

Kees van Dieren
Senior Software Engineer

MP Objects Software for E-logistics
Stationsplein 45
3013 AK Rotterdam
The Netherlands

Post address:
Postbus 29126
3001 GC Rotterdam

Mobile: +31 (0)6-43068619
Phone: +31 (0)10-2900304
Fax: +31 (0)10-2900305

-----Original Message-----
From: Kunze, Kai [mailto:[hidden email]]
Sent: Monday, May 09, 2005 2:33 PM
To: [hidden email]
Subject: Problems with Axis on JBoss 4.0

Hi all,

I hope u guys can help me.

I had a WebService running on Jboss 3.2.6, which I deployed with the
AdminClient-Tool and a self-written deploy.wsdd file.
It all worked fine and it was easy to deploy. Now we upgraded to
4.0.1sp1 and there are severeal problems that I have now.

1. The AdminClient-Tool doesnt work anymore. I tried to deploy the WS
the same way as before but it doesnt work. The output was something like
"..Connection failed!..".

2. So I tried to create a WAR-package. But I have HashMaps in my WS as
return-type, and JBoss wont accept them. Do I have to specify such
things in the "jaxrpc-mapping.xml" - file? If I cut out all
HashMap-methods, Jboss accepts the WAR-file.

3. I have problems to specify the correct endpoint of the WS.
F.e. u know that the Version-Service is by default at:
"http://server-dns-name:8080/ws4ee/services/Version?wsdl"
I want my WS to be located at:
"http://server-ds-name:8080/ws4ee/services/WS-Name?wsdl"
Actually my WebService is at:
"http://server-IP:8080/WS-Name/ws4ee/services/WS-Name?wsdl"

The worst thing is, that I cant access it by ist dns-name, only directly
by the IP. I dont specify the IP in any XML-File. How can that happen?

In which file do I set it? Which tag do i use?
- web.xml?
- jaxrpc-mapping.xml ?
- webservice.xml ?

If u think u can help me, I can send u XML-Files and Source Code if u
like...

Greetings and thx in advance,

Kai

--
Kai Kunze
Braunschweig, Germany