[jira] [Commented] (AXIS2-5898) Axis2 uses old version of HTTPClient/HTTPComponent Java library

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

[jira] [Commented] (AXIS2-5898) Axis2 uses old version of HTTPClient/HTTPComponent Java library

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/AXIS2-5898?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16207620#comment-16207620 ]

George Stanchev commented on AXIS2-5898:

The practice of asking questions by submitting a JIRA issues is frowned upon. It creates a burden on the project maintainers to clean up such JIRAs as they are not real bugs or enhancements. You should use the mailing list to ask questions about the product.

Second, the very first link (i am feeling lucky) in a google search for "axis2 httpclient 4" is: https://axis.apache.org/axis2/java/core/release-notes/1.7.0.html which describes how to switch to HTTP Client 4

> Axis2 uses old version of HTTPClient/HTTPComponent Java library
> ---------------------------------------------------------------
>                 Key: AXIS2-5898
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5898
>             Project: Axis2
>          Issue Type: Improvement
>         Environment: Matlab 2017b, on Windows Server 2012 R2
>            Reporter: Marius Kist
> Hello,
> for work I have to access grib2 file subsets via OPeNDAP with climate data using Matlab.
> For this task we employ the Matlab toolbox nctoolbox.
> This toolbox relies on a the netCDF Java API to access container formats (e.g. hdf5, netCDF, grib2).
> The newer Versions of netCDF java use a current version of the Java library HTTPClient.
> Matlab uses (within the axis2 framework) a very old version of HTTPClient (Applications/MATLAB_R2017b.app/java/jarext/axis2/commons-httpclient.jar).
> Therefore, nctoolbox is bound to use a very old version of the netCDF Java API, to be conform with the Matlab version of HTTPClient.
> As a user this conflicting HTTPClient versions are a problem for me.
> I cannot benefit from bugfixes which were done in newer versions of netCDF Java API.
> My question is: Will axis2 be upgraded to the current version of HTTPClient in future releases ?
> Best regards
> Marius

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]